The current .NET SDK does not support targeting …

Error NETSDK1045: .NET Standard 2.1, .NET Core 3.0

I just installed .NET Core 3.0, and began trying it. However, running nuget restore on my sln give the errors:

error NETSDK1045: The current .NET SDK does not support targeting .NET Standard 2.1
error NETSDK1045: The current .NET SDK does not support targeting .NET Core 3.0
  • If you do, create a global.json file in the root of your project(s) directory:
{
"sdk": {
"version": "3.0.100"
}
}

I’ve learned I don’t know anything. I've also learned that people will pay for what I know. Maybe that's why they never pay.

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store